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Certificate Error

Overview

The SSL certificate was changed on the servers in Feb-2019.  Customers running old In-Store applications that were not updated after the certificate update might experience security certificate related errors. You should follow the steps below to fix certificate errors.

 


Diagnosis

  • An error will be displayed indicating there is a problem with the security certificate, preventing updating the device
  • An error will be displayed when running the Diagnostic/Transfer flow.

 


Solution

 

Remote access to the affected device is required to resolve this issue. Here are two process options to resolve this issue:


Option 1 - Update the Application

The latest version of the In-Store application includes a fix to prevent these errors. The simplest option would be to download and install the newest version of the application.

Online Software Update
  • If the Mobilogy In-Store Solutions platform is connected to the internet, and the updated license is valid, an automatic background process will compare the updated server content with the installed version.
  • This process is invoked every 20 minutes, starting with the first activation of the Mobilogy In-Store Solutions platform or when it wakes up from sleep mode.
  • If there is a new version, a message will appear, informing the user of the update, as per the image below.

 

mceclip0.png

 

  • Online updates can be performed in any of the following methods:
    • Pull update: By using the Update button to the right of the notification message (as displayed above, or by selecting the update software from the server option of the Settings screen under the Update tab.
    • Forced update: Available on Touch2 units only, this customer pack enabled feature performs automatic updates if the unit is idle for more than a set period.
    • Scheduled updates: This customer pack enabled feature will perform an automatic update on a predefined schedule if the unit or workstation is idle.
  • To perform a Pull update software update:
    1. Open Main Menu.
    2. Select the Update button.
    3. Or from the Update tab of the Setting screen, select the Update version from Server option.
    4. The update process will start.

      mceclip1.png

    5. When completed, the device will restart automatically.

 

Manual Software Update

Follow these steps to update manually:

  1. From the Toolbar Menu, select the Settings icon to open the Settings screen.
  2. Under the Update tab, select Refresh to see if there is an updated version of the software.

    mceclip2.png

  3. If an updated version exists, select the update from Server option to install the software update from the server automatically.
  4. Alternatively, download the software update file on a USB mass storage device.
    1. Insert the USB mass storage device into one of the rear panel USB ports in the back of the device.
    2. Select the update from the USB option.
    3. Select the software package you wish to install, and then select Continue.

      mceclip3.png

  5. The update process begins. When done, the device will restart automatically.

Option 2 - Manually Remove Old Certificates

Here, you will be required to remove the old certificates from Windows Certificate Manager manually.

  1. Open Windows Certificate Manager.
    1. Open Run.
    2. Type certlm.msc
    3. Click OK.

  2. Expand the Trusted Publishers > Certificates folder.
  3. Proceed to remove all the certificates that have *.mobilogy.com in the Issued To field.

    mceclip4.png

  4. If you are uncertain which Certificate needs to be removed:
    1. Open the certificate by double-clicking on it.

      certificate.jpg

    2. Confirm if the certificate is issued to *.mobilogy.com
    3. If it is, delete the certificate by right-clicking on the certificate and Delete.
  5. You can now re-launch the application and run diagnostics on the device.

 

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Testing

  • Once the application has been re-launched, run a diagnostic session to test the resolution.
  • No errors should be received.
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  1. Priyanka Bhotika

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