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Unable to Update / Update Failing

Overview

While trying to update the software, the screen might be frozen, or the installer might fail, therefore you can not update the software. Automatic updates may also not work. See the steps below to fix the update problems so that you can update the software to the latest version.

 


Diagnosis

  • Update fails, or update screen freezes because the previous installer was interrupted (e.g. restart due to power loss) or the device is corrupt.
  • The automatic update can not find the latest version because you are using an old version that cannot find the latest version due to a known bug.

 

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Solution

There might be 2 cases causing the update failures. First, we will try to address the easier root cause:  Software is corrupt or it is an old version with a bug

Then, if the solution above does not work, we will conclude that the root cause is the second case:
Devices is corrupt

Follow the steps below that address each case.

 

Case 1 -  Software is corrupt or old

 

Step 1: Uninstall the Mobilogy Application and all the related Mobilogy software.

  1. In Windows, go to Control Panel.
  2. Select Programs.
  3. Select Programs and Features.
  4. Go over the Publisher column's title.
  5. Click on the drop-down arrow.
  6. Select Mobilogy from the list to filter the programs.
  7. Right-click on each Mobilogy program and click Uninstall
     
    mceclip0.png
     
    mceclip1.png

    Important: If the uninstall task fails, please follow the instructions in this article on Uninstalling a Corrupted Installation of Mobilogy Software.

 

Step 2: Download and install the latest version manually

  1. Follow the instructions in the Updating a Touch 2 Device to the Latest Version

 

Case 2 -  Device is corrupt

 

Step 1: Apply Recovery Process

  1. Follow the instructions in the Recovery Process for Touch Devices

Step 2: Download and install the latest version manually

  1. Follow the instructions in the Updating a Touch 2 Device to the Latest Version

 

 

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Testing

 

To test if the Software installed correctly, complete the following steps: 

  1. Open the Mobilogy Touch 2 software by clicking on the Desktop Icon:

  2. It will open a new window that says "Preparing the list of devices..."

    mceclip9.png
  3. You will see a yellow bar advising that there is a new update available. Click on Update:

    mceclip10.png
  4. A new screen will open saying that the software is being downloaded. 

    mceclip13.png
  5. Wait for it until finish and it will install automatically the software and restart the device:

    mceclip12.png
  6. When the device starts again, you can open the software, go to the Settings ( mceclip14.png ) Icon and the About tab to confirm that you have the latest version installed:

    mceclip15.png

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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