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Increasing the Logging Level for Log files

Overview

By default, Mobilogy Now logs events at the ERROR level. You can change this if you need to gather more information (If you are troubleshooting specific problems with Transfers or Diagnostics feature, for example).

As a best practice, you should not increase logging levels except when troubleshooting an issue. Increasing the log level to debug or trace increases the amount of information being logged and can have a significant impact on performance.

 


Diagnosis

This guide can be applied in the following scenario(s):

  • When you receive an Error or Unhandled Exception and you want to deep troubleshoot the issue to understand the root cause.
  • When you receive an Error or Unhandled Exception and a regular log is not catching the root cause of the problem.
  • You have to be an administrator/have administrator credentials on the Windows account (Or ate least have Write access on the logs folder to be able to modify log files). 

 

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Solution

 

Prerequisites

  • Having access to the Device's software.

 

To increase the Logging level, please follow these steps:

  1. Navigate to C:\Program Files (x86)\Cellebrite Mobile Synchronization\<Cellebrite Installation>.

    Replace the <Cellebrite Installation> tag with the correct installation folder name.

    mceclip0.png

  2. Look for the files log_config.xml and log4cxx.xml.

By default, only error-level logs are enabled. To enable debug-level logs (maximum level), open these files and replace the ERROR keywords with the DEBUG keyword. For example:

Change each line with the following string:

<levelMin value="ERROR" />

To

<levelMin value="DEBUG" />

 

You should only set a logging level to debug when investigating a specific issue. Reproduce the issue and then reset the logging level back to its default value.  

 

  • To decrease the logging level, change back the value from DEBUG to ERROR.

 

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Testing

To test properly this feature, after following the aforementioned guide, please do the following:

  1. Stop the Mobilogy Application.
  2. Delete the log files obtained by following the Obtaining the Mobilogy Now Log files.
  3. Start Mobilogy and reproduce the issue or Task. (New logs will be created with a higher level of Logging)
  4. Extract again the logs using the  Obtaining the Log files KB Article
  5. Check the logs to troubleshoot the issue further.

At this point, the logs should've changed to reflect a deeper analysis of the behavior observed by the user.

 

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  1. Priyanka Bhotika

  2. Posted
  3. Updated

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